Ankündigung

Einklappen
Keine Ankündigung bisher.

[behoben in 1.5.4] Update 1.5.1 auf 1.5.3 - da läuft was schief - LÖSUNG

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    [behoben in 1.5.4] Update 1.5.1 auf 1.5.3 - da läuft was schief - LÖSUNG

    Hallo,

    wir hatten hier heute einen Shop von 1.5.1 auf 1.5.3 upzudaten - das funktionierte mehr schlecht als recht. Irgendwo kommt der zc_install Vorgang auf die Idee, dass er die Konstante
    Code:
    DIR_WS_CLASSES
    mit
    Code:
    ../includes/classes/
    belegt.
    Das geht natürlich schief und erzeugt im Logfile entsprechende Fehlereinträge wenn man versucht die Datenbank upzugraden.

    Die Lösung schafft hier die Zeile 52 in der Datei
    Code:
    includes/classes/class.zcPassword.php
    wie folgt zu ändern:

    alt:
    PHP-Code:
    require_once (DIR_FS_CATALOG DIR_WS_CLASSES 'vendors/password_compat-master/lib/password.php'); 
    neu:
    PHP-Code:
    require_once (DIR_FS_CATALOG .  '/includes/classes/vendors/password_compat-master/lib/password.php'); 
    WICHTIG: Nach dem Update die Änderung wieder rückgängig machen.

    Das selbe Problem ist auch im englischsprachigen Forum beschrieben und wurde dort genauso gelöst.

    @WEBCHILLS: ich denke es macht Sinn diesen Tip sticky zu machen oder die Datei class.zcPassword.php entsprechend zu patchen - ich denke da werden noch mehr drüber fallen, die PHP 5.4 bzw PHP > 5.3.7 verwenden. Bei PHP 5.5.x wird das ganze nicht auftreten.

    lg
    Andreas

    #2
    Ist in der demnächst erscheinenden Version 1.5.4 behoben mit:
    Code:
     public function __construct($phpVersion = PHP_VERSION)
      {
        if (version_compare($phpVersion, '5.3.7', '<')) {
          require_once (realpath(dirname(__FILE__)) . '/../functions/password_compat.php');
        } elseif (version_compare($phpVersion, '5.5.0', '<')) {
          require_once (realpath(dirname(__FILE__)) . '/vendors/password_compat-master/lib/password.php');
        }
      }

    Kommentar


      #3
      Zitat von webchills Beitrag anzeigen
      Ist in der demnächst erscheinenden Version 1.5.4 behoben mit:
      Code:
       public function __construct($phpVersion = PHP_VERSION)
        {
          if (version_compare($phpVersion, '5.3.7', '<')) {
            require_once (realpath(dirname(__FILE__)) . '/../functions/password_compat.php');
          } elseif (version_compare($phpVersion, '5.5.0', '<')) {
            require_once (realpath(dirname(__FILE__)) . '/vendors/password_compat-master/lib/password.php');
          }
        }
      Frage: Kann das auch beim Update in 1.5.3 verwendet werden, und wenn ja, wo muss das hinkopiert werden? Ich bin gerade dabei, die Version 1.5.1 upzudaten, mein Provider verwendet derzeit noch PHP Version 5.3.29. Da ich das Update auf 1.5.3 derzeit erst lokal mit Xampp durchführe, welches PHP Version 5.6.3 verwendet, gab es beim Update auch kein Problem. Aber sobald der Live-Shop zum Update ansteht würde ich gerne das angesprochene Problem vermeiden. Oder sollte ich gleich noch auf 1.5.4 warten? Demnächst ist ja ein dehnbarer Begriff und ich bin seit Tagen am mergen, da spart man sich gerne unnötige Mühen.

      Kommentar


        #4
        Es geht hier um die Datei includes/classes/class.zcPassword.php

        Dort ab ca. Zeile 47 ändern von:
        Code:
          public function __construct($phpVersion = PHP_VERSION)
          {
            if (version_compare($phpVersion, '5.3.7', '<')) {
              require_once (DIR_FS_CATALOG . DIR_WS_FUNCTIONS . 'password_compat.php');
            } elseif (version_compare($phpVersion, '5.5.0', '<')) {
              require_once (DIR_FS_CATALOG . DIR_WS_CLASSES . 'vendors/password_compat-master/lib/password.php');
            }
          }
        auf

        Code:
         public function __construct($phpVersion = PHP_VERSION)
          {
            if (version_compare($phpVersion, '5.3.7', '<')) {
              require_once (realpath(dirname(__FILE__)) . '/../functions/password_compat.php');
            } elseif (version_compare($phpVersion, '5.5.0', '<')) {
              require_once (realpath(dirname(__FILE__)) . '/vendors/password_compat-master/lib/password.php');
            }
          }
        Das kannst Du auch in 1.5.3 machen.

        Ich würde ruhig mit dem Update auf 1.5.3 weitermachen bzw. auf 1.5.3 updaten. Ein späteres Update von 1.5.3 auf 1.5.4 wird sehr leicht zu machen sein und ist nicht vergleichbar mit dem Aufwand eines Updates von früheren Versionen. Es wird für das Update von 1.5.3 auf 1.5.4 ein Updatepackage geben, das man einfach einspielt. Erscheinungstermin voraussichtlich: Mitte bis Ende April.
        Zuletzt geändert von webchills; 02.04.2015, 21:23.

        Kommentar

        Info zu diesem Forenarchiv:
        Mit Release von 1.5.7 wurde die deutsche Zen Cart Version auf eine reine DIY-Lösung umgestellt.
        Für einen Support via Forum stehen keine personellen und zeitlichen Ressourcen mehr zur Verfügung.
        Dieses Supportforum bleibt im Nur-Lesen-Modus als Wissensarchiv noch online verfügbar.
        PM Funktionalität, Registrierung und Posten neuer Beiträge sind deaktiviert.
        Zugriff auf Anhänge in den Postings ist auch ohne Registrierung/Einloggen möglich.
        FAQ und Downloadbereich des Forums wurden in die neue umfangreiche Knowledgebase auf der zen-cart-pro.at Website übernommen.

        Das Development der deutschen Zen Cart Version geht wie bisher auf Github weiter.
        Wir werden auch weiterhin neue Versionen bereitstellen und die Onlinedokumentation/Knowledgebase aktualisieren.
        Fehler in der Software können auf Github als Issues gemeldet werden.
        Follow us
        aktuelle version
        Zen Cart 1.5.7f deutsch
        vom 21.12.2022
        [Download]
        Lädt...
        X