Ankündigung

Einklappen
Keine Ankündigung bisher.

Zen-Cart Update für PayPal Website Payments Pro

Einklappen
Dieses Thema ist geschlossen.
X
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Zen-Cart Update für PayPal Website Payments Pro

    PayPal wird am 01. September 2009 Änderungen beim Gateway für Payflow vornehmen.
    Betroffen davon sind nur:
    1) Shops, die das Zahlungsmodul PayPal Website Payments Pro einsetzen
    2) Shops, die PayPal Express mit einem PayPal UK Account (PayPal Großbritannien) nutzen

    PayPal IPN oder PayPal Express mit einem deutschen oder österreichischen Paypal-Account sind nicht betroffen. Wer das einsetzt, muss nichts ändern!

    Wer in seinem Zen-Cart Shop Paypal Website Payments Pro oder PayPal Express mit PayPal UK einsetzt, muss aber bis 31. August folgende Änderungen vornehmen:

    Zen-Cart 1.3.8

    In den Dateien
    includes/modules/payment/paypalwpp.php
    (ca. Zeile 1040)
    und
    includes/modules/payment/paypaldp.php
    (ca. Zeile 886)

    Code:
    $doPayPal->_endpoints = array('live'    => 'https://payflowpro.verisign.com/transaction',
                                        'sandbox' => 'https://pilot-payflowpro.verisign.com/transaction');
    Ändern auf:
    Code:
    $doPayPal->_endpoints = array('live'    => 'https://payflowpro.paypal.com',
                                        'sandbox' => 'https://pilot-payflowpro.paypal.com');
    Zen-Cart 1.3.7

    In der Datei
    includes/modules/payment/paypalwpp.php
    (ca. Zeile 1012)

    Code:
    $doPayPal->_endpoints = array('live'    => 'https://payflowpro.verisign.com/transaction',
                                        'sandbox' => 'https://pilot-payflowpro.verisign.com/transaction');
    Ändern auf:
    Code:
    $doPayPal->_endpoints = array('live'    => 'https://payflowpro.paypal.com',
                                        'sandbox' => 'https://pilot-payflowpro.paypal.com');
    Zen-Cart 1.3.6 und älter

    Zen-Cart 1.3.6 und älter haben kein PayPal Express oder Website Payments Pro integriert. Für diese Versionen gab es ein Addon für die PayPal Express Unterstützung. Dieses Addon wird ab 01.09. von PayPal nicht mehr unterstützt! Wer in alten Zen-Cart Versionen mit diesem alten Addon arbeitet, muss den Shop auf 1.3.8 updaten, um weiterhin PayPal Website Payments Pro nutzen zu können.

    Weitere Infos dazu:
    http://www.zen-cart.com/forum/showth...782#post705782
Info zu diesem Forenarchiv:
Mit Release von 1.5.7 wurde die deutsche Zen Cart Version auf eine reine DIY-Lösung umgestellt.
Für einen Support via Forum stehen keine personellen und zeitlichen Ressourcen mehr zur Verfügung.
Dieses Supportforum bleibt im Nur-Lesen-Modus als Wissensarchiv noch online verfügbar.
PM Funktionalität, Registrierung und Posten neuer Beiträge sind deaktiviert.
Zugriff auf Anhänge in den Postings ist auch ohne Registrierung/Einloggen möglich.
FAQ und Downloadbereich des Forums wurden in die neue umfangreiche Knowledgebase auf der zen-cart-pro.at Website übernommen.

Das Development der deutschen Zen Cart Version geht wie bisher auf Github weiter.
Wir werden auch weiterhin neue Versionen bereitstellen und die Onlinedokumentation/Knowledgebase aktualisieren.
Fehler in der Software können auf Github als Issues gemeldet werden.
Follow us
aktuelle version
Zen Cart 1.5.7 deutsch
vom 20.05.2022
[Download]
Lädt...
X