Ankündigung

Einklappen
Keine Ankündigung bisher.

Fehlermeldung bei Kundenlogin

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Fehlermeldung bei Kundenlogin

    Hallo,
    hab das Forum schon durchwühlt, vermutlich habe ich aber als einziger Mensch auf dieser Welt diesen wunderbaren Fehler.

    Registirert sich ein Kunde im Shop ist das okay Kommt der Kunde jedoch wieder und möchte sich einloggen erscheint laufend diese Fehlermeldung:

    " Es gab einen Sicherheitsfehler, als Sie versucht haben sich anzumelden."

    Langsam werde ich kirre, was für einen Sicherheitsfehler meint das System?
    Hat einer eine Idee?

    Danke Euch vorab und Viele Grüsse
    todo

    #2
    Was den fehler genau ist weis ich nicht, ich habe es ab uns zu wen ich in meinen admin rein will... (von kunden habe ich es noch nie gehört) aber beim zweiten mal einloggen klappt es immer.

    Schätze hat was zu tun mit sessions im PHP config vom server aber weil es meinen wissens nur bei mein adminlogin ist und nur jeden 3. oder 4. Woche mal passiert habe ich mich da noch nicht drum gekümmert.

    Kommentar


      #3
      hi,

      ja, das könnte evtl. bei meinem kunden-login auch der Grund sein.
      Danke für den Tipp, ich schau mal die Einstellungen durch. Im Admin Bereich hab ich jedoch das Problem nicht!!! Ein Admin versucht es halt schon gerne mehrmals, ein Kunde schmeisst jedoch verzweifelt das Handtuch)

      Werde das Ergebnis dann hier posten--
      Dir erstmal Besten Dank)
      cu
      todo

      Kommentar


        #4
        Zitat von madquad Beitrag anzeigen
        erscheint laufend diese Fehlermeldung
        Es ist also nie ein Login für den Kunden möglich und es kommt diese Meldung immer?
        Dann bin ich mir ziemlich sicher, dass Du ein altes Logintemplate in 1.3.8 verwendest, das die Security Token nicht übergibt.
        Überprüfe Deine includes/templates/DEINTEMPLATE/templates/tpl_login_default.php
        Unterhalb der Passwortfelder muss folgender Eintrag sein
        Code:
        <?php echo zen_draw_hidden_field('securityToken', $_SESSION['securityToken']); ?>
        Genau dasselbe muss in der includes/templates/DEINTEMPLATE/template/tpl_time_out_default.php sein.

        Kommentar


          #5
          login

          Bingo,

          super.... danke Dir!!!!!!!!!!!!!!!!!!!!!
          Das war´s!

          cu
          todo

          Kommentar


            #6
            noch immer Probleme

            in welcher reihenfolge sind die zeilen anzuordnen?

            in meinen vorliegenden templatedateien

            gibt es verschiedene versionen?
            mal mit der Zeile

            <?php echo zen_draw_hidden_field('securityToken', $_SESSION['securityToken']); ?>
            mal ohne die zeile.

            kann es noch weitere fehlerquellen für das login problem geben?

            danke an alle!

            Kommentar


              #7
              Die includes/templates/DEINTEMPLATE/templates/tpl_login_default.php enthält den betreffenden Abschnitt für das Passwort immer zweimal.
              Einmal für die Seite, die erscheint, wenn man die Loginseite geteilt anzeigen lässt und einmal für die Seite, die erscheint, wenn man sie nicht geteilt anzeigen lässt.

              Hier die entsprechenden Abschnitte, wie es aussehen muss:

              ab ca. Zeile 48, der ist für die geteilte Loginanzeige

              Code:
              <label class="inputLabel" for="login-password"><?php echo ENTRY_PASSWORD; ?></label>
              <?php echo zen_draw_password_field('password', '', 'size="18" id="login-password"'); ?>
              <?php echo zen_draw_hidden_field('securityToken', $_SESSION['securityToken']); ?>
              <br class="clearBoth" />
              ab ca. Zeile 72, der ist für die normale Loginanzeige

              Code:
              <label class="inputLabel" for="login-password"><?php echo ENTRY_PASSWORD; ?></label>
              <?php echo zen_draw_password_field('password', '', zen_set_field_length(TABLE_CUSTOMERS, 'customers_password') . ' id="login-password"'); ?>
              <br class="clearBoth" />
              <?php echo zen_draw_hidden_field('securityToken', $_SESSION['securityToken']); ?>

              Kommentar


                #8
                login problem

                riesen dankeschön an webchills

                gaaaaaanz großes kino !

                top service - wie immer

                Kommentar


                  #9
                  Hallo,

                  woran kann es noch liegen, dass der Kunden Login nicht mehr funktionniert?
                  Es kommt jedesmal die Meldung "ERROR_SECURITY_ERROR".
                  Der Shop wurde von 1.3.7 auf 1.3.9h upgedatet (Falls wichtig: aktuelle Php Version 5.3.8., Datenbak Patch Level 1.3.9f)

                  Das Zufügen der Zeile
                  <?php echo zen_draw_hidden_field('securityToken', $_SESSION['securityToken']); ?> hat keine Änderung bewirkt.

                  Auch nach dem Aufspielen des Back-up von vor dem Update ist das Login-Problem leider immer noch vorhanden. Vor dem Update hat das einwandfrei funktionniert.

                  Ausser der Info mit der Zeile hinzufügen habe ich nichts gefunden, was das Problem lösen könnte.

                  danke im voraus für Eure Bemühungen

                  claudine

                  Kommentar


                    #10
                    Hast Du die includes/templates/DEINTEMPLATE/templates/tpl_login_default.php so wie oben beschrieben an beiden Stellen geändert?

                    Kommentar


                      #11
                      ja das war gestern gemacht worden ..
                      habe das jetzt nochmal überprüft, die Zeile nochmal neu rein kopiert, 2 mal wie beschrieben und jetzt funktionniert es !! ... warum es gestern abend nicht geklappt hat, verstehe ich nicht.

                      DANKE

                      Kommentar


                        #12
                        Fehlermeldung bei Kundenlogin - als Kunde!

                        Ich habe das gleiche Problem, nur von der anderen Seite aus gesehen: Ich habe international bei zwei Onlinehändlern eingekauft, die beide mit Zen-Cart arbeiten.

                        Nach erfolgreicher Registrierung, Bestellung und Vorkasse-Zahlung kann ich mich in beiden Shops nicht mehr als Kunde anmelden, um Einblick in mein Kundenkonto zu nehmen. Es erscheint die besagte Fehlermeldung "Es gab einen Sicherheitsfehler, als Sie versucht haben sich anzumelden".

                        An falsch eingegebenem Login oder Paßwort liegt's definitiv nicht; ich habe mir mehrfach neue Paßwörter zuschicken lassen und kann mich trotzdem nicht einloggen.

                        Dummerweise rühren sich beide Verkäufer nach meinen Bestellungen nicht und ich kann mich nicht in die Zen-Cart-Kundenkonten einloggen, um nach dem Bearbeitungsstand meiner Aufträge zu schauen. Das Login-Problem in Zen-Cart scheint also nicht so vereinzelt aufzutreten wie oben erwähnt vermutet. Nachteilig für den Verkäufer und seine(n) Kunden - solche Probleme sind im Zeitalter des (globalen) Onlineshoppings nicht mehr zeitgemäß und verunsichern den Kunden massiv...

                        Kommentar


                          #13
                          Zitat von ottawa Beitrag anzeigen
                          Dummerweise rühren sich beide Verkäufer nach meinen Bestellungen nicht und ich kann mich nicht in die Zen-Cart-Kundenkonten einloggen, um nach dem Bearbeitungsstand meiner Aufträge zu schauen. Das Login-Problem in Zen-Cart scheint also nicht so vereinzelt aufzutreten wie oben erwähnt vermutet. Nachteilig für den Verkäufer und seine(n) Kunden - solche Probleme sind im Zeitalter des (globalen) Onlineshoppings nicht mehr zeitgemäß und verunsichern den Kunden massiv...
                          Die Software kann nichts dafür wenn sie falsch konfiguriert wird oder bei einem Update Uralt-Templates unverändert weiterverwendet werden. Sie kann auch nichts dafür, wenn ein Shopbetreiber nicht auf Emails reagiert.

                          Kommentar

                          Info zu diesem Forenarchiv:
                          Mit Release von 1.5.7 wurde die deutsche Zen Cart Version auf eine reine DIY-Lösung umgestellt.
                          Für einen Support via Forum stehen keine personellen und zeitlichen Ressourcen mehr zur Verfügung.
                          Dieses Supportforum bleibt im Nur-Lesen-Modus als Wissensarchiv noch online verfügbar.
                          PM Funktionalität, Registrierung und Posten neuer Beiträge sind deaktiviert.
                          Zugriff auf Anhänge in den Postings ist auch ohne Registrierung/Einloggen möglich.
                          FAQ und Downloadbereich des Forums wurden in die neue umfangreiche Knowledgebase auf der zen-cart-pro.at Website übernommen.

                          Das Development der deutschen Zen Cart Version geht wie bisher auf Github weiter.
                          Wir werden auch weiterhin neue Versionen bereitstellen und die Onlinedokumentation/Knowledgebase aktualisieren.
                          Fehler in der Software können auf Github als Issues gemeldet werden.
                          Follow us
                          aktuelle version
                          Zen Cart 1.5.7 deutsch
                          vom 20.05.2022
                          [Download]
                          Lädt...
                          X